Вопрос задан 20.06.2023 в 14:50. Предмет Информатика. Спрашивает Бабаев Эльмар.

1. написать программу, которая выводит факториал числа 2. Прграмма, которая выводит N первых

чисел фибоначчи 3. Программа, которая находит сумму первых N простых чисел ПИТОН!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Григорьева Катя.

Ответ:

1)

from math import factorial

print(factorial(int(input())))

2)

f1 = f2 = 1

n = int(input())

print(f1, f2, end=' ')

for i in range(2, n):

   f1, f2 = f2, f1 + f2

   print(f2, end=' ')

3)

j = int(input())

summ = 0

for n in range(2, j + 1):

   if n > 1:

       for i in range(2, n):

               if (n % i) == 0:

                   break

       else:

           summ += n

print(summ)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

1. Программа, которая выводит факториал числа: ```python def factorial(n): if n == 0: return 1 else: return n * factorial(n-1)

num = int(input("Введите число: ")) print("Факториал числа", num, "равен", factorial(num)) ```

2. Программа, которая выводит N первых чисел Фибоначчи: ```python def fibonacci(n): fib = [0, 1] for i in range(2, n): fib.append(fib[i-1] + fib[i-2]) return fib

num = int(input("Введите количество чисел Фибоначчи: ")) print(num, "первых чисел Фибоначчи:", fibonacci(num)) ```

3. Программа, которая находит сумму первых N простых чисел: ```python def is_prime(num): if num < 2: return False for i in range(2, int(num**0.5) + 1): if num % i == 0: return False return True

def sum_of_primes(n): count = 0 num = 2 total = 0 while count < n: if is_prime(num): total += num count += 1 num += 1 return total

num = int(input("Введите количество простых чисел: ")) print("Сумма первых", num, "простых чисел:", sum_of_primes(num)) ```

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос