Вопрос задан 20.06.2023 в 10:45.
Предмет Информатика.
Спрашивает Майорова Пелагея.
100 БАЛЛОВ!!! Написать программу, выводящую на экран таблицу умножения. Код программы должен
содержать внешнюю рекурсивную функцию.Язык СиОтветы на вопрос
Отвечает Смолин Иван.
1 using namespace std;
2 #include <iostream>
3
4
5 int main(int argc, char* argv[ ])
6 {
7 int n;
8 cout << "Input number->";
9 cin >> n;
10 for (int i = 1; i < 11; i++)
11 {
12 cout << n << "*" << i << "=" << n*i << '\n';
13 }
14 system("pause");
15 return 0;
16 }
Вроде верно, код написан на языке C++
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
#include
void printMultiplicationTable(int num, int count) { if (count > 10) { return; } printf("%d x %d = %d\n", num, count, num * count); printMultiplicationTable(num, count + 1); }
int main() { int num; printf("Enter a number to print its multiplication table: "); scanf("%d", &num);
printMultiplicationTable(num, 1);
return 0; }
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
