
Решить на C++ Вид треугольника Напишите программу, которая принимает три положительных числа и
определяет вид треугольника, длины сторон которого равны введенным числам. Формат входных данных На вход программе подаются три числа – длины сторон существующего треугольника. Формат выходных данных Программа должна вывести на экран текст – вид треугольника («Равносторонний», «Равнобедренный» или «Разносторонний»).

Ответы на вопрос

#include <iostream>
using namespace std;
int main()
{
setlocale(0, "");
int a{}, b{}, c{};
cin >> a >> b >> c;
if (a == b && a == c)
cout << "Равносторонний";
else if (a == b || a == c || b == c)
cout << "Равнобедренный";
else
cout << "Разносторонний";
return 0;
}



Для решения данной задачи можно использовать следующий алгоритм: 1. Получить значение длин сторон треугольника. 2. Проверить, существует ли треугольник с такими сторонами. Для этого сумма двух коротких сторон должна быть больше третьей стороны. 3. Если треугольник существует, то проверить его тип. - Если все три стороны равны, то треугольник равносторонний. - Если две стороны равны, то треугольник равнобедренный. - Если все три стороны разные, то треугольник разносторонний. 4. Вывести на экран соответствующий тип треугольника.
Пример программы на языке Python:
```python # Ввод длин сторон треугольника a = float(input("Введите длину стороны a: ")) b = float(input("Введите длину стороны b: ")) c = float(input("Введите длину стороны c: "))
# Проверка существования треугольника if a + b > c and a + c > b and b + c > a: # Проверка типа треугольника if a == b and b == c: print("Равносторонний треугольник") elif a == b or a == c or b == c: print("Равнобедренный треугольник") else: print("Разносторонний треугольник") else: print("Треугольник со сторонами заданных длин не существует") ```
Данная программа позволяет ввести длины сторон треугольника и определить его тип: "Равносторонний", "Равнобедренный" или "Разносторонний".


Похожие вопросы
Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili