Вопрос задан 19.06.2023 в 18:45. Предмет Информатика. Спрашивает Килина Аня.

Введите массив. состоящий из 12 целых чисел. Составьте программу, определяющие количество эле-

ментов, которые кратны 2. но не кратны 5​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Станіславський Ярослав.

Ответ:

def func(arr):

   coun=0

   for i in range(len(arr)):

       if arr[i]%2==0 and arr[i]%5!=0:

           coun+=1

   return coun

Объяснение:

Функция принимает массив(любого размера) и выводит количество подходящих элементов. Написано на Python, но принцип работы везде один

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи вам потребуется написать программу на языке программирования, которая будет определять количество элементов в массиве, которые кратны 2, но не кратны 5.

Давайте начнем с создания массива, состоящего из 12 целых чисел. В языке Python это может выглядеть следующим образом:

```python numbers = [1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12] ```

Однако, поскольку в вашем вопросе не указаны конкретные числа, вы можете ввести собственные значения для массива.

Затем вам нужно создать переменную, которая будет считать количество элементов, удовлетворяющих условию (кратны 2, но не кратны 5). Мы назовем эту переменную `count`. Изначально она будет равна 0.

```python count = 0 ```

Затем вам нужно пройти по всем элементам массива и проверить каждый элемент на соответствие условию. Если элемент кратен 2 и не кратен 5, увеличивайте значение переменной `count` на 1.

```python for number in numbers: if number % 2 == 0 and number % 5 != 0: count += 1 ```

После прохождения всех элементов массива, в переменной `count` будет храниться количество элементов, которые кратны 2, но не кратны 5.

Вот полный код программы на языке Python:

```python numbers = [1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12] count = 0

for number in numbers: if number % 2 == 0 and number % 5 != 0: count += 1

print("Количество элементов, кратных 2, но не кратных 5:", count) ```

Вы можете запустить эту программу и она выведет количество элементов, удовлетворяющих условию.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос