Вопрос задан 19.06.2023 в 15:51. Предмет Информатика. Спрашивает Лубченков Иван.

Python 1) Программа получает на вход количество чисел в последовательности (натуральное число), а

затем сами числа (целые). Найдите произведение чисел последовательности не кратных 52) Программа получает на вход количество чисел в последовательности (натуральное число), а затем сами числа (целые). Найдите количество чисел последовательности оканчивающихся на четную цифру3) Вводятся два натуральных числа а и с. На отрезке от 0 до а, найдите все числа, последняя цифра которых кратна с Python
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Верховный Далер.

1)

# На вход: кол-во чисел, сами числа

# Выход: кол-во чисел не кратных 5

count:int = input('Кол-во чисел?: ')

ints = []

for i in range(int(count)):

   ints.append(input('Число ' + str(i+1) + ': '))

result = []

for i in ints:

   if int(i) % 5 != 0:

       result.append(i)

print(result)

2)

# На вход: кол-во чисел, сами числа

# Выход: кол-во чисел в конце которых чётное число

count:int = input('Кол-во чисел?: ')

ints = []

for i in range(int(count)):

   ints.append(input('Число ' + str(i+1) + ': '))

result = []

for i in ints:

   if int(i) % 2 == 0:

       result.append(i)

print(result)

3)

# На вход: числа A и C

# Выход: числа, последняя цыфра которых кратна С

A = input('Отрезок от 0 до ')

C = input('Найти числа, кратные ')

result = []

for i in range(0, int(A)):

   if i % int(C) == 0:

       result.append(i)

   

print(result)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, давайте начнем с написания программ на Python для решения этих задач.

1) Найдем произведение чисел последовательности, не кратных 5. Для этого программу можно написать так:

```python # Ввод количества чисел в последовательности n = int(input("Введите количество чисел в последовательности: "))

# Инициализация переменной для хранения произведения произведение = 1

# Ввод чисел последовательности и нахождение произведения чисел, не кратных 5 for i in range(n): число = int(input(f"Введите число {i+1}: ")) if число % 5 != 0: произведение *= число

print("Произведение чисел последовательности, не кратных 5, равно:", произведение) ```

2) Теперь найдем количество чисел в последовательности, оканчивающихся на четную цифру:

```python # Ввод количества чисел в последовательности n = int(input("Введите количество чисел в последовательности: "))

# Инициализация счетчика чисел, оканчивающихся на четную цифру количество_четных_цифр = 0

# Ввод чисел последовательности и подсчет чисел, оканчивающихся на четную цифру for i in range(n): число = int(input(f"Введите число {i+1}: ")) последняя_цифра = число % 10 if последняя_цифра % 2 == 0: количество_четных_цифр += 1

print("Количество чисел последовательности, оканчивающихся на четную цифру, равно:", количество_четных_цифр) ```

3) Найдем все числа на отрезке от 0 до `a`, последняя цифра которых кратна `c`:

```python # Ввод натуральных чисел a и c a = int(input("Введите натуральное число a: ")) c = int(input("Введите натуральное число c: "))

# Нахождение чисел на отрезке от 0 до a с последней цифрой, кратной c числа = [number for number in range(a + 1) if number % 10 == c or (number == 0 and c == 0)]

print(f"Числа на отрезке от 0 до {a}, последняя цифра которых кратна {c}, равны:", числа) ```

Это основные программы на Python для решения каждой из задач. Я могу объяснить, как они работают, если нужно.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос