Вопрос задан 19.06.2023 в 11:06. Предмет Информатика. Спрашивает Байниязов Каримулла.

Напишите программу, которая будет проверять какое сейчас время года. Она будет спрашивать у

пользователя номер месяца (от 1 – Январь до 12 – декабрь), а затем выводить сообщение в консоль о том, какое это время года. Например, если номер месяца 5 (май), то программа выведет сообщение “Сейчас весна”. У нас уже есть проверка на правильность ввода, если пользователь введет число меньше 1 или больше 12, то программа выводит сообщение об ошибке, ведь такого месяца не существует.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Парач Николай.

Программа:

Python:

def month(m):

   if m == 1 or m == 2 or m == 12:

       print('Сейчас зима')

   elif m == 3 or m == 4 or m == 5:

       print('Сейчас весна')

   elif m == 6 or m == 7 or m == 8:

       print('Сейчас лето')

   elif m == 9 or m == 10 or m == 1:

       print('Сейчас осень')

   else:

       print('Такого месяца не существует')

if __name__ == '__main__':

   m = int(input())

   month(m)

0 0
Отвечает Юрчишин Влад.

Ответ:

N = int(input())

if N < 1 or N > 12:

   print('Ошибка')

else:

   if N in [1, 2, 12]:

       season = 'зима'

   elif N in [3, 4, 5]:

       season = 'весна'

   elif N in [6, 7, 8]:

       season = 'лето'

   elif N in [9, 10, 11]:

       season = 'осень'

   print('Сейчас ' + season)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи можно использовать конструкцию "if-else" и "switch-case" для определения времени года в зависимости от введенного номера месяца.

Вот пример программы на языке Python:

```python month = int(input("Введите номер месяца (от 1 до 12): "))

if month < 1 or month > 12: print("Ошибка. Такого месяца не существует") else: if month == 1 or month == 2 or month == 12: print("Сейчас зима") elif month >= 3 and month <= 5: print("Сейчас весна") elif month >= 6 and month <= 8: print("Сейчас лето") else: print("Сейчас осень") ```

Программа запрашивает у пользователя номер месяца и сохраняет его в переменную `month`. Затем она проверяет, находится ли номер месяца в диапазоне от 1 до 12. Если введенное число не входит в этот диапазон, программа выводит сообщение об ошибке.

Если число находится в допустимом диапазоне, программа сравнивает его с определенными значениями, чтобы определить, какое время года соответствует введенному номеру месяца. При выполнении соответствующего условия программа выводит сообщение о текущем времени года.

Например, если пользователь вводит число 5, программа выводит сообщение "Сейчас весна".

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос