Вопрос задан 19.06.2023 в 11:05. Предмет Информатика. Спрашивает Байконырова Балауса.

Язык программирования C# Задачка : Есть аттракцион. У посетителя; 1) Есть билет 2) Возраст >

15 3) Рост > 120 Вывести сообщение можно ли пройти.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Куликова Сонечка.

using System;

namespace restless

{

   class Visitor

   {

       private bool ticket;

       private int age;

       private int height;

       public void InputInfo()

       {

           c:

           Console.Write("Наличие билета: (Да/Нет): ");

           string t = Console.ReadLine().ToLower();

           if (t == "да")

               ticket = true;

           else if (t == "нет")

               ticket = false;

           else

           {

               Console.WriteLine("Вы ввели что-то не то...");

               goto c;

           }

           

           Console.Write("Ваш возраст: ");

           age = Convert.ToInt32(Console.ReadLine());

           Console.Write("Ваш рост: ");

           height = Convert.ToInt32(Console.ReadLine());

       }

       public bool CheckPeople()

       {

           if (ticket == true && age > 15 && height > 120)

               return true;

           return false;

       }

   }

   class Program

   {

       static void Main(string[] args)

       {    

           Visitor ch1 = new Visitor();

           ch1.InputInfo();

           if (ch1.CheckPeople())

               Console.WriteLine("Вам можно пройти!");

           else

               Console.WriteLine("Увы, но пройти Вам нельзя!");

       }

       

   }

}


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, давай разберем эту задачу шаг за шагом.

Тебе нужно написать программу на языке программирования C#, которая проверяет, может ли посетитель пройти на аттракцион. У тебя есть три условия:

1. Посетитель имеет билет. 2. Возраст посетителя больше 15 лет. 3. Рост посетителя больше 120 см.

Чтобы проверить все эти условия в коде, можно использовать конструкцию if-else. Вот пример, как это можно сделать на C#:

```csharp using System;

class Program { static void Main() { bool hasTicket = true; // есть ли у посетителя билет (true - есть, false - нет) int age = 16; // возраст посетителя int height = 130; // рост посетителя

if (hasTicket && age > 15 && height > 120) { Console.WriteLine("Вы можете пройти на аттракцион!"); } else { Console.WriteLine("К сожалению, вы не можете пройти на аттракцион."); } } } ```

В этом примере мы создаем переменные `hasTicket`, `age` и `height`, которые содержат информацию о наличии билета, возрасте и росте посетителя соответственно. Затем мы используем условный оператор `if`, чтобы проверить все три условия: наличие билета, возраст больше 15 и рост больше 120. Если все три условия выполняются (что обозначается оператором `&&`, который означает логическое "и"), то выводится сообщение о том, что посетитель может пройти на аттракцион. В противном случае выводится сообщение о том, что пройти нельзя.

Это базовый пример, который можно доработать в зависимости от реальной реализации программы или добавить дополнительные проверки и действия в коде.

0 0

Похожие вопросы

Последние заданные вопросы в категории Информатика

Задать вопрос