Вопрос задан 19.06.2023 в 08:16. Предмет Информатика. Спрашивает Гулаков Никита.

ЗАДАЧА НА ПИТОНЕ ДАЮ 25 БАЛЛОВ . Рабочие поднимают на грузовом лифте ящики. Если ящик весит

больше 180 кг, то лифт отказывается его поднимать. Напишите программу, которая будет подсчитывать, сколько ящиков было поднято на грузовом лифте и общую массу ящиков, которые лифт поднять не смог.С клавиатуры вводятся массы всех ящиков (в кг), символ окончания ввода - это ноль.Формат входных данныхПоследовательность целых положительных чисел, на конце ноль.Формат выходных данныхОтвет в формате:Было поднято N ящиков, но еще K кг груза ожидают внизу.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ивановская Яна.

boxes = []

count = 0

waiting = 0

for i in range(10):

  new_box = (int(input(f"Введите массу {i} ящика")))

  if new_box > 180:

     waiting = waiting + new_box

  else:

     count = count + 1

     boxes.append(new_box)

print(f"Было поднято {count} ящиков, но ещё {waiting} кг груза ожидают внизу.")


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на Python, которая решает вашу задачу:

```python total_boxes = 0 # Общее количество поднятых ящиков total_weight_below_limit = 0 # Общая масса ящиков, которые лифт не смог поднять

while True: weight = int(input("Введите массу ящика в кг (введите 0 для завершения ввода): "))

if weight == 0: break # Прерываем цикл при вводе 0

if weight > 180: print(f"Лифт отказывается поднимать ящик весом {weight} кг.") total_weight_below_limit += weight else: print(f"Ящик весом {weight} кг поднят на грузовом лифте.") total_boxes += 1

print(f"Было поднято {total_boxes} ящиков, но еще {total_weight_below_limit} кг груза ожидают внизу.") ```

Программа запрашивает ввод массы каждого ящика. Если масса ящика больше 180 кг, программа выводит сообщение о том, что лифт отказывается поднимать этот ящик, и увеличивает общую массу ящиков, которые лифт не смог поднять. В противном случае программа увеличивает общее количество поднятых ящиков. Когда вводится 0, программа завершает ввод и выводит общее количество поднятых ящиков и общую массу ящиков, которые лифт не смог поднять.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос