Составьте программу в Pascal ABC используя простые команды(9 класс). Вводится существительное
первого склонения в единственном числе (имена существительные женского, мужского рода, имеющие в именительном падеже единственного числа окончание -а (-я)). Программа должна выводить это существительное во множественном числе. Пример: страна страны; земля ---- земли. 30 баллов.Ответы на вопрос
Ответ:
program zadanie4b;
var su:string;
begin
write('Введите существительное первого склонения в единственном числе:');readln(su);
if su[length(su)]='а' then
writeln(copy(su,1,length(su)-1)+'ы') else
if su[length(su)]='я' then
writeln(copy(su,1,length(su)-1)+'и')
end.
Объяснение:
Конечно, вот пример программы на Pascal ABC, которая принимает существительное первого склонения в единственном числе и выводит его во множественном числе:
```pascal program PluralNouns;
var singularNoun, pluralNoun: string;
begin // Запрос ввода существительного writeln('Введите существительное в единственном числе (именительный падеж): '); readln(singularNoun); // Проверка на окончание и изменение во множественное число if (singularNoun[length(singularNoun)] = 'а') or (singularNoun[length(singularNoun)] = 'я') then pluralNoun := copy(singularNoun, 1, length(singularNoun) - 1) + 'и' else pluralNoun := singularNoun + 'ы'; // Вывод во множественном числе writeln('Во множественном числе: ', pluralNoun); end. ```
Эта программа запрашивает у пользователя существительное в единственном числе в именительном падеже, определяет его род и склонение, и выводит его во множественном числе.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
