
НА ПАСКАЛЕ! Напишите программу, которая заполняет массив из N=10 элементов случайными числами в
диапазоне [0,20], выводит его на экран, а затем находит индекс первого элемента, равного введенному числу X. Программа должна вывести ответ "не найден", если в массиве таких элементов нет. Пример: Массив: 5 16 2 13 3 14 18 13 16 9 Что ищем: 13 A[4] = 13

Ответы на вопрос

const
N = 10;
var
arr : array[1..N] of integer;
x, i, idx : integer;
begin
idx := -1;
randomize;
write('Массив: ');
for i := 1 to N do
begin
arr[i] := random(21);
write(arr[i],' ');
end;
writeln;
write('Что ищем: ');
readln(x);
for i := 1 to N do
if (arr[i] = x) then
begin
idx := i;
break;
end;
if idx = -1 then
writeln('Не найден')
else
writeln('A[',idx,']',' = ',x);
end.



Программа, решающая данную задачу на языке Pascal, может выглядеть следующим образом:
```pascal program FindIndex;
var arr: array[1..10] of integer; i, n, x, index: integer; found: boolean;
begin // Заполняем массив случайными числами Randomize; for i := 1 to 10 do begin arr[i] := Random(21); Write(arr[i], ' '); end; // Вводим число, которое будем искать WriteLn; Write('Введите число для поиска: '); ReadLn(x); // Ищем первое вхождение числа в массиве found := false; for i := 1 to 10 do begin if arr[i] = x then begin index := i; found := true; Break; end; end; // Выводим результат if found then WriteLn('Индекс первого найденного элемента равного ', x, ': ', index) else WriteLn('Не найдено'); end. ```
Объявляем переменные: - `arr` - массив из 10 элементов для хранения случайных чисел - `i` - счётчик для цикла - `n` - количество элементов в массиве (в данной задаче фиксировано значение 10) - `x` - число, которое нужно найти в массиве - `index` - переменная для хранения индекса первого найденного элемента - `found` - флаг, указывающий на наличие в массиве элемента, равного числу `x`
Запускаем генератор случайных чисел с помощью функции `Randomize`, чтобы получать каждый раз новую последовательность случайных чисел.
Заполняем массив `arr` случайными числами от 0 до 20 и выводим его на экран.
Считываем число `x` с помощью `ReadLn`.
Запускаем цикл `for i := 1 to 10 do` для поиска первого вхождения числа `x` в массив `arr`. Если элемент `arr[i]` равен `x`, то сохраняем `i` в переменную `index`, устанавливаем флаг `found` в значение `true` и выходим из цикла с помощью команды `Break`.
После цикла выводим результат на экран с помощью конструкции `if found then ... else ...`. Если флаг `found` равен `true`, то выводим сообщение с найденным индексом элемента. Если флаг `found` равен `false`, то выводим сообщение "Не найдено".
Таким образом, программа создает массив случайных чисел, находит первое вхождение введенного числа в массиве и выводит результат.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili