в среде программирования Pascal сформируйте и выведите в строку через пробел без комментариев
массив Z, состоящий из восьми элементов, заданных по формуле i*i+1. На следующей строке выведите, чему равна сумма элементов массива ZОтветы на вопрос
Ответ:
Pascal
var
z: array[1..8] of integer;
i, s:integer;
begin
s:=0;
for i:= 1 to 8 do begin
z[i]:=i*i+1;
write(z[i],' ');
s:=s+z[i];
end;
writeln();
write('Сумма элементов = ', s)
end.

Я могу помочь вам с написанием кода на Pascal. Вот пример кода, который формирует и выводит массив Z из восьми элементов, заданных по формуле i*i+1, а также сумму его элементов:
```pascal program array_z; var Z: array[1..8] of integer; // объявляем массив Z из 8 целых чисел i, sum: integer; // объявляем переменные i и sum для цикла и суммы begin sum := 0; // инициализируем сумму нулем for i := 1 to 8 do // цикл от 1 до 8 begin Z[i] := i*i+1; // вычисляем i-й элемент массива по формуле sum := sum + Z[i]; // добавляем i-й элемент к сумме end; for i := 1 to 8 do // цикл от 1 до 8 begin write(Z[i], ' '); // выводим i-й элемент массива с пробелом end; writeln; // переходим на новую строку writeln('Сумма элементов массива Z равна ', sum); // выводим сумму элементов массива end. ```
Если вы запустите этот код, вы получите следующий результат:
``` 2 5 10 17 26 37 50 65 Сумма элементов массива Z равна 212 ```
Надеюсь, это поможет вам понять, как работать с массивами на Pascal.
Похожие вопросы
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
