Вопрос задан 18.06.2023 в 07:50. Предмет Информатика. Спрашивает Никитина Анастасия.

Требуется написать программу, которая для массива состоящего из n целочисленных элементов заданных

случайным образом, определяет количество элементов меньших 60, но больших 10. !!!!!!!!!!!!(PASCAL ABC)!!!!!!!!!!!!ПИШИТЕ ПОЖАЙЛУЙСТА ЧТО ЗА ЧТО ОТВЕЧАЕТ СРОЧНО!!!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Серов Данила.

const n = 10; //объявляем константу, можно менять число на любое другое

var A: array[1..n] of integer; // объявляем массив из n элементов

var k: integer; // объявляем перменную-счетчик

begin

k := 0;

for var i:= 1 to n do begin

A[i] := random(101); // присваиваем рандомное значение от 0 до 100

write (A[i], ' '); //выводим массив, можно убрать эту команду

if (A[i] > 10) and (A[i] < 60) then // проверяет условия

k := k + 1; // если выполняются оба условия, увеличивает счетчик на 1

end;

writeln; // переход на новую строку для красоты

write('Кол-во элементов больше 10, но меньше 60: ', k); // выводит кол-во элементов

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

К сожалению, я не могу предоставить вам готовый код на Pascal ABC, так как мой редактор не поддерживает выполнение кода. Однако я могу предоставить вам общую структуру программы на Pascal ABC, которая решит вашу задачу.

```pascal program CountElements; var arr: array of integer; n, count: integer; i: integer;

begin // Ввод размера массива write('Введите размер массива: '); readln(n);

// Инициализация массива и подсчет элементов SetLength(arr, n); count := 0;

// Заполнение массива случайными числами и подсчет элементов for i := 0 to n - 1 do begin arr[i] := Random(100); // Здесь 100 - максимальное значение элемента массива (может быть изменено по вашему усмотрению) writeln('arr[', i, '] = ', arr[i]);

// Подсчет элементов if (arr[i] > 10) and (arr[i] < 60) then count := count + 1; end;

// Вывод результата writeln('Количество элементов больше 10 и меньше 60: ', count);

// Завершение программы readln; end. ```

В этой программе создается массив случайных целых чисел, и затем происходит подсчет элементов, удовлетворяющих условиям (больше 10 и меньше 60). Количество таких элементов выводится на экран.

Пожалуйста, убедитесь, что вы понимаете код, и при необходимости внесите изменения в соответствии с вашими требованиями.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос