Вопрос задан 18.06.2023 в 07:11. Предмет Информатика. Спрашивает Рогоза Ваня.

1. Заполните массив кубами случайных целых чисел в интервале (1,5). Перемножьте все элементы списка

с четными индексами (то есть A[0], A[2], A[4], ...). Входные данные Вводится список чисел. Все числа списка находятся на одной строке. Выходные данные Выведите ответ на задачу. 2. Заполните массив из 10 элементов. Выведите на экран произведение четных элементов. Входные данные Вводится список чисел. Все числа списка находятся на одной строке. Выходные данные Выведите ответ на задачу. Ответом на задачи является программа на языке python.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Китов Макс.

Программа:

Python:

№1)

A = list(input().split())

pr = 1

for i in range(len(A)):

   if i % 2 == 0:

       pr *= int(A[i])

print(f'{A}\n{pr}')

№2)

from random import randint

arr = [randint(-10, 10) for i in range(10)]  # массив из 10 чисел от -10 до 10

pr = 1

for i in arr:

   if i % 2 == 0 and i != 0:  pr *= i

print(f'{arr}\n{pr}')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программы на языке Python для решения ваших задач:

1. Заполните массив кубами случайных целых чисел в интервале (1, 5). Перемножьте все элементы списка с четными индексами:

```python import random

# Ввод массива кубами случайных целых чисел в интервале (1, 5) A = [random.randint(1, 5)**3 for _ in range(10)]

# Перемножение элементов с четными индексами result = 1 for i in range(0, len(A), 2): result *= A[i]

# Вывод результата print(result) ```

2. Заполните массив из 10 элементов. Выведите на экран произведение четных элементов:

```python # Ввод массива из 10 элементов B = [int(input()) for _ in range(10)]

# Вычисление произведения четных элементов even_product = 1 for num in B: if num % 2 == 0: even_product *= num

# Вывод результата print(even_product) ```

Просто вставьте код в вашу среду выполнения Python и введите необходимые числа для второй задачи. Код для первой задачи создает массив случайных чисел, поэтому дополнительный ввод не требуется.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос