Вопрос задан 18.06.2023 в 05:06. Предмет Информатика. Спрашивает Зубков Кирилл.

1. Напишите программу, которая запрашивает фамилии студентов и их почтовые адреса, записывает

полученные данные в файл "номер_группы.txt" и выводит список из файла на экран (Решение этой задачи может быть разным: самое простое - организовать ввод и запись данных по одной строке, более сложный вариант - организовать цикл из нескольких итераций, их количество можно уточнять у пользователя: "Сколько строк данных Вы хотите ввести?" или спрашивать после ввода одной строки: "Ввести еще данные?" и т.п. Здесь можно решить любым способом, который Вам понятен на данном этапе изучения языка). Язык Питон
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Назаров Владислав.

Ответ:

num = input('Введите номер группы: ')

while True:

   command = input('Ввести данные?\n(y/n) ')

   if command == 'y':

       surname = input('Введите фамилию: ')

       email = input('Введите почту: ')

       if input('Внести данные?\n(y/n) ') == 'y':

           with open(f'{num}.txt', mode='a', encoding='utf-8') as f:

               f.write(f'{surname} - {email}')

           print('Данные записаны')

       else:

           print('Запись данных отменена')

   else:

       print('Выход...')

       break

with open(f'{num}.txt', mode='r', encoding='utf-8') as f:

   data = f.read()

print('Фамилия - Почта')

print(data)

Вроде как вполне работает


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Python, которая запрашивает фамилии студентов и их почтовые адреса, записывает полученные данные в файл "номер_группы.txt" и выводит список из файла на экран:

```python def write_student_data(): group_number = input("Введите номер группы: ") num_students = int(input("Сколько студентов в группе? "))

with open(f"{group_number}.txt", "w") as file: for _ in range(num_students): name = input("Введите фамилию студента: ") email = input("Введите почтовый адрес: ") file.write(f"{name}: {email}\n")

with open(f"{group_number}.txt", "r") as file: student_list = file.readlines()

print("Список студентов:") for student in student_list: print(student.strip())

write_student_data() ```

Программа начинается с запроса номера группы и количества студентов в группе. Затем она открывает файл с именем "номер_группы.txt" для записи данных. В цикле программа запрашивает фамилию студента и его почтовый адрес, после чего записывает эти данные в файл. Затем программа открывает файл для чтения и выводит список студентов на экран.

Примечание: В данном примере предполагается, что все введенные данные корректны и не требуют дополнительной валидации. Также необходимо учесть, что при каждом запуске программы файл будет перезаписываться, поэтому предыдущие данные будут потеряны.

Надеюсь, это поможет вам создать программу для записи данных студентов и вывода списка на экран. Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать их!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос