Вопрос задан 18.06.2023 в 03:14. Предмет Информатика. Спрашивает Кузнецов Артём.

ПОМОГИТЕ пожаллуйстосоставте программу которая позволяет определить, будет ли введеннаястрока

являться "Перевертышем после удаления из нее всезх пробелов". КИТ НА МОРЕ РОМАНТИК
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Дешевов Тимофей.

Ответ:

string = ''.join(input().split())

if string == string[::-1]:

   print('Это строка-перевертыш!')

else:

   print('Не-а')

Объяснение:

Метод .split() разделяет строку по определенному символу (по умолчанию - пробел)

Метод ''.join() соединяет список по символу (в данном случае по пустому символу)

string[::-1] - копирует строку с шагом -1, тем самым переворачивает её


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на каком-либо языке программирования, чтобы определить, является ли введенная строка "перевертышем" после удаления из нее всех пробелов. Давайте напишем пример на Python.

```python def is_palindrome_after_spaces_removal(s): # Удаляем все пробелы из строки s_without_spaces = ''.join(s.split())

# Проверяем, является ли новая строка перевертышем return s_without_spaces == s_without_spaces[::-1]

# Пример использования user_input = input("Введите строку: ") result = is_palindrome_after_spaces_removal(user_input)

if result: print("Введенная строка является перевертышем после удаления пробелов.") else: print("Введенная строка не является перевертышем после удаления пробелов.") ```

Этот код определяет функцию `is_palindrome_after_spaces_removal`, которая принимает строку и возвращает `True`, если строка становится палиндромом после удаления из нее всех пробелов, и `False` в противном случае. Затем программа запрашивает у пользователя ввод строки и выводит соответствующее сообщение. В вашем примере, если введенная строка будет "КИТ НА МОРЕ РОМАНТИК", программа вернет `True`, так как после удаления пробелов получится строка "КИТНАМОРЕРОМАНТИК", которая является палиндромом.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос