Вопрос задан 18.06.2023 в 01:34. Предмет Информатика. Спрашивает Сердюкова Елизавета.

Помогите ПОЖАЛУЙСТА. НУЖНА ПРОГРАММА НА С++ ЗАДАНИЕ: [В массиве B(20) найти сумму элементов с

номерами 1,2,7,9,16.]
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Тарасенко Світланка.

Ответ:

Листинг прикрепил в скриншоте.

Код в объяснении

Объяснение:

#include <iostream>  

int main() {

   int B[20] = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20 };

   int result = B[1] + B[2] + B[7] + B[9] + B[16];

   std::cout << "result: " << result << std::endl;

   return 0;

}


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на языке программирования C++, чтобы решить данную задачу. Вот пример кода:

```cpp #include

int main() { const int size = 20; int B[size] = { /* Ваш массив B с 20 элементами */ }; // Найти сумму элементов с номерами 1, 2, 7, 9, 16 int indices[] = {1, 2, 7, 9, 16}; int sum = 0;

for (int i = 0; i < sizeof(indices) / sizeof(indices[0]); ++i) { int index = indices[i];

if (index >= 0 && index < size) { sum += B[index]; } else { std::cout << "Ошибка: Индекс " << index << " вне диапазона массива." << std::endl; // Можно добавить обработку ошибки, если это необходимо // Например, завершить программу или выполнить другие действия return 1; // Возвращаем код ошибки } }

std::cout << "Сумма элементов с номерами 1, 2, 7, 9, 16: " << sum << std::endl;

return 0; // Возвращаем нулевой код, чтобы указать успешное выполнение программы } ```

В данном коде мы создали массив `B` размером 20 элементов. Затем мы создали массив `indices`, содержащий номера элементов, которые нужно сложить. Программа проходит по этим индексам, проверяет их допустимость (чтобы избежать выхода за границы массива) и суммирует соответствующие элементы массива `B`. Полученная сумма выводится на экран.

Не забудьте заменить комментарий `/* Ваш массив B с 20 элементами */` на ваш собственный массив данных.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос