
Составить программу на C++ (желательно с объяснениями, что и как) Посчитайте количество элементов
одномерного массива, которые совпадают со своим номером и при этом кратные 3.

Ответы на вопрос

using namespace std;
#include <iostream>
#include <clocale>
#include <cstdlib>
#include <iomanip>
#include <string>
#include <ctime>
int main() {
setlocale(LC_ALL, "rus");
system("chcp 1251");
srand(time(0));
const int arraysize = 50;
int array[arraysize];
int count = 0;
for (int i = 0; i < arraysize; i++) {
array[i] = rand() % 50;
if (i % 3 == 0 && array[i] == i) count++;
cout << array[i] << " ";
}
cout << endl << endl << "Количество чисел, совпадающих со своим номером и кратных трем: " << count << endl;
system("pause");
return 0;
}



Ответ:
Все расписал в объяснении писал прогу в DevC++.
Объяснение:
//Пишу на DevC++
#include <stdio.h>//ввод и вывод
#include <stdlib.h>//Не помню прочитаешь
#include <math.h>//Математические действия на всякий случай подключил
#include <locale.h>//Библиотечка для подключения русского
#include <time.h>//Лаборатория со временем подключаю чтобы настроить рандом
int main(){ //Объявление самой программы
setlocale(LC_ALL, "rus"); //Подключение русского языка(чтобы при выводе на экран русский выводил)
int s, i, N = 1000, count = 0; //Объявление переменных
int A[N], B[N]; //Объявление массивов
system("color 2"); //Ставим себе цвет текста
printf("Весь массив: \n\n"); //Выводим на экран текст
for(i=1; i<1000;i++){ //Цикл for(начальное значение; конечное значение; шаг(на сколько идет увеличение или уменьшение)
A[i] = rand()%1000; //Цикл в котором i-ому элементу массива присваивается рандомное число от 0 до 1000
} //Закрытая скобка закрытие цикла
for(i=1; i<1000;i++){ //Снова цикл for
printf("%d\t", A[i]); //Вывод на экран поочередно элементы массива
} //Закрытая скобка
printf("\n\nМассив в котором элемент совпадает со своим номером:\n");//Вывод текста
for(i=1; i<1000;i++){ //Цикл for
if(i==A[i]){ //Цикл if равнение в скобках равно ли i и элемент массива A[i]
if(A[i] % 3 == 0){ //Если остаток от деления числа массива с номером i на 3 равно 0 (деление без остатка) то идем в цикл
printf("%d\t", A[i]); //Выводим на экран все числа массива удовлетворяющие условию
count+=1; //счетчик
} //Закрыто
} //Закрыто
} //Закрыто
if(count == 0) printf("\nТаких элементов нет\n"); //Если счетчик равен нулю выводим строку
printf("\nКоличество элементов которые совпадают со своим номером: %d\n", count);//выводим строку и вписываем в конце число счетчика
} //Закрыто




Программа на C++ для подсчета количества элементов одномерного массива, которые совпадают со своим номером и при этом кратные 3
```cpp
#include
int main() { const int SIZE = 10; // размер массива int arr[SIZE] = {0, 3, 6, 9, 12, 15, 18, 21, 24, 27}; // инициализация массива
int count = 0; // счетчик элементов, удовлетворяющих условию
for (int i = 0; i < SIZE; i++) { if (arr[i] == i && arr[i] % 3 == 0) { count++; } }
cout << "Количество элементов одномерного массива, которые совпадают со своим номером и при этом кратные 3: " << count << endl;
return 0; } ```
Объяснение программы: 1. Включаем заголовочный файл `iostream`, чтобы использовать стандартные потоки ввода-вывода. 2. Используем директиву `using namespace std`, чтобы не писать `std::` перед стандартными именами. 3. Определяем константу `SIZE`, которая будет определять размер массива. В данном случае, размер массива равен 10. 4. Создаем одномерный массив `arr` и инициализируем его значениями, которые совпадают со своим номером и кратны 3. 5. Объявляем переменную `count`, которая будет использоваться для подсчета количества элементов, удовлетворяющих условию. 6. Используем цикл `for` для перебора всех элементов массива. 7. Внутри цикла проверяем, совпадает ли значение элемента массива с его индексом (`arr[i] == i`) и является ли оно кратным 3 (`arr[i] % 3 == 0`). 8. Если условие выполняется, увеличиваем значение переменной `count` на 1. 9. После завершения цикла, выводим значение переменной `count`, которое будет содержать количество элементов, удовлетворяющих условию.
Программа выводит количество элементов одномерного массива, которые совпадают со своим номером и при этом кратные 3.
Пример вывода: ``` Количество элементов одномерного массива, которые совпадают со своим номером и при этом кратные 3: 4 ```
Например, в данной программе массив `arr` содержит следующие элементы: `[0, 3, 6, 9, 12, 15, 18, 21, 24, 27]`. Из этих элементов только 0, 3, 6 и 9 удовлетворяют условию и являются кратными 3. Таким образом, количество элементов, удовлетворяющих условию, равно 4.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili