
В массиве из 100 натуральных чисел до 300 найти те,которве заканчиваются на 8 на паскале написать


Ответы на вопрос

var
cnt, i :integer;
a : array[1..100] of integer;
begin
randomize;
cnt := 0;
for i := 1 to 100 do
begin
a[i] := random(300) + 1;
write(a[i], ' ');
if a [i] mod 10 = 8 then
cnt := cnt + 1;
end;
writeln;
writeln('Количество чисел, которые оканчиваются на 8: ', cnt);
end.



Для решения данной задачи вам потребуется написать программу на языке Паскаль, которая будет искать числа в массиве из 100 натуральных чисел до 300, оканчивающиеся на 8. Вот пример программы на Паскале, которая решает данную задачу:
```pascal program FindNumbersEndingWithEight;
const ARRAY_SIZE = 100;
var numbers: array[1..ARRAY_SIZE] of Integer; i: Integer;
begin // Заполняем массив случайными натуральными числами до 300 for i := 1 to ARRAY_SIZE do numbers[i] := Random(300) + 1;
// Ищем числа, оканчивающиеся на 8 for i := 1 to ARRAY_SIZE do begin if numbers[i] mod 10 = 8 then WriteLn(numbers[i]); end; end. ```
В этой программе мы создаем массив `numbers` размером 100 и заполняем его случайными натуральными числами до 300. Затем мы проходим по всем элементам массива и выводим на экран только те числа, которые оканчиваются на 8.
Примечание: Для компиляции и запуска программы на Паскале вам потребуется среда разработки, такая как Turbo Pascal или Lazarus IDE.
Надеюсь, это поможет вам решить задачу! Если у вас возникнут еще вопросы, не стесняйтесь задавать их.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili