Вопрос задан 17.06.2023 в 19:22. Предмет Информатика. Спрашивает Кожахметов Елдар.

Написать программу в тетради. Массив состоит из 5 случайных чисел от 0 до 99. Найти сколько

элементов в массиве имеют максимальное значение.Пожалуйста
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Нефедченко Антон.

Ответ: python

import random

a = [0] * 5

for i in range(len(a)):

   a[i] = random.randint(0, 99)

c = 0

m = max(a)

for j in range(len(a)):

   if a[j] == m:

       c += 1

print(c)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Python, которая решает вашу задачу:

```python import random

# Создаем массив из 5 случайных чисел от 0 до 99 array = [random.randint(0, 99) for _ in range(5)]

# Находим максимальное значение в массиве max_value = max(array)

# Считаем количество элементов в массиве, которые имеют максимальное значение count = array.count(max_value)

# Выводим результат print(f"В массиве {array} {count} элементов имеют максимальное значение {max_value}.") ```

Эта программа создает массив из 5 случайных чисел от 0 до 99, находит максимальное значение в массиве и подсчитывает количество элементов, которые имеют это максимальное значение. Результат выводится на экран.

Примечание: Каждый раз, когда вы запускаете эту программу, массив будет содержать новые случайные числа, поэтому результат может отличаться при каждом запуске.

Надеюсь, это поможет вам! Если у вас возникнут еще вопросы, пожалуйста, дайте мне знать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос