
Паскаль: вывести все счастливые числа на промежутке от а до б (а и б нужно вводить). Сколько цифр в
числе не указано.Пожалуйста, подскажите, от этого задания и оценки зависит годовой табель Ось українською: вивести всі щасливі числа на проміжку від а до б

Ответы на вопрос

Если будут вопросы - задавай.
var
m : array of integer;
a, b, i, j : integer;
procedure DelEl(ind:integer);
var
t:integer;
begin
for t := ind to length(m)-2 do
m[t]:=m[t+1];
setlength(m, length(m)-1);
end;
procedure ClearZ;
var
c:integer;
begin
c:=0;
while c < length(m) do
if m[c]=0 then
DelEl(c)
else
inc(c)
end;
procedure RemElem(p:integer);
var
step:integer;
begin
step:=m[p];
j:=step-1;
while j < length(m) do begin
m[j]:=0;
j:=j+step;
end;
end;
begin
write('Введите a :');
readln(a);
write('Введите b :');
readln(b);
(*заполним массив натуральными числами в диапазоне*)
SetLength(m, b);
for i := 1 to b do
m[i-1]:=i;
(*исключим все чётные числа*)
RemElem(1);
ClearZ;
(*проходим решетом по массиву*)
i:=1;
while i<length(m) do begin
RemElem(i);
ClearZ;
inc(i);
end;
(*печатаем счастливые числа в диапазоне*)
for i:= 0 to length(m)-1 do
if m[i]>=a then
write(m[i], ' ');
end.




Паскаль: Вывод всех счастливых чисел на промежутке от a до b
Для того чтобы вывести все счастливые числа на промежутке от a до b в языке программирования Паскаль, можно использовать следующий алгоритм:
1. Определить, что такое счастливое число. 2. Написать программу, которая будет проверять числа на счастливость в заданном диапазоне.
Что такое счастливое число?
Счастливым числом называется натуральное число, которое при замене его цифр на квадраты этих цифр и последующем сложении этих квадратов равно единице.
Программа на Паскале для вывода всех счастливых чисел на промежутке от a до b
```pascal program HappyNumbers;
function IsHappyNumber(num: integer): boolean; var sum, digit: integer; begin sum := 0; while num > 0 do begin digit := num mod 10; sum := sum + digit * digit; num := num div 10; end; IsHappyNumber := (sum = 1); end;
var a, b: integer; begin // Ввод значений a и b writeln('Введите значение a: '); readln(a); writeln('Введите значение b: '); readln(b);
// Поиск и вывод счастливых чисел на промежутке от a до b writeln('Счастливые числа на промежутке от ', a, ' до ', b, ':'); for a := a to b do begin if IsHappyNumber(a) then writeln(a); end; end. ```
Сколько цифр в числе не указано?
Из предоставленных данных не ясно, на какое именно число или задачу относится вопрос "Сколько цифр в числе не указано?". Пожалуйста, уточните, чтобы я мог предоставить более точный ответ.
Оценка и годовой табель
Для получения оценки и годового табеля, рекомендуется обратиться к преподавателю или учебному заведению, где вы изучаете Паскаль или другие предметы.


Похожие вопросы

Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili