Вопрос задан 29.06.2018 в 11:13.
Предмет Информатика.
Спрашивает Волк Рома.
Составить программу для решения задачи: Дана строка. Проверить правильность написания слов с ЖИ-ШИ.
Если слово написано неправильно,то исправить его.Ответы на вопрос
Отвечает Янков Диас.
Var a:string;
i:longint;
begin
readln(a);
for i := 2 to length(a) do
begin
if (a[i] = 'ы') then
if (a[i-1] = 'ж') or (a[i-1] = 'ш') then a[i] := 'и';
end;
writeln(a);
end.
Отвечает Мубараков Мадияр.
Var s:string; p1,p2:integer;
begin
writeln('Введите слово:');
readln(s);
p1:=pos('жы',s);
p2:=pos('шы',s);
if (p1=0)and(p2=0) then writeln('Ошибок не замечено.');
if p1>0 then
begin
delete(s,p1,2);
insert('жи',s,p1);
writeln('Слово написано с ошибкой.');
writeln('Правильное написание - ',s);
end;
if p2>0 then
begin
delete(s,p2,2);
insert('ши',s,p2);
writeln('Слово написано с ошибкой.');
writeln('Правильное написание - ',s);
end;
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
