Вопрос задан 16.06.2023 в 17:10. Предмет Информатика. Спрашивает Говорушко Соня.

Паскаль и только паскаль Написать программу вычисления стоимости покупки с учетом скидки. Скидка

в 5% предоставляется в том случае, если сумма покупки больше 1000 руб., в 10% - если сумма больше 1500 руб.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Замалиев Рафаэль.

var

 s:integer;

begin

 write('Введите сумму покупки: '); readln(s);

 if s>1500 then

   writeln('Итог с учётом скидки 10%: ',0.90*s)

     else

       if s>1000 then

         writeln('Итог с учётом скидки 5%: ',0.95*s)

           else

             writeln('Итог: ',s);

end.

Если моё решение вам помогло, отметьте его как лучшее. Спасибо! Удачи!

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь тебе написать программу на Паскале, которая вычисляет стоимость покупки с учетом скидки. Вот примерный код:

```pascal program Discount; var price, discount, total: real; begin writeln('Введите сумму покупки в рублях:'); readln(price); if price > 1500 then discount := 0.1 // 10% скидка else if price > 1000 then discount := 0.05 // 5% скидка else discount := 0; // нет скидки total := price * (1 - discount); // итоговая сумма writeln('Скидка составляет ', discount * 100:0:2, '%'); writeln('Итоговая сумма покупки составляет ', total:0:2, ' руб.'); end. ```

Я надеюсь, что это поможет тебе. Если ты хочешь узнать больше о Паскале, ты можешь посмотреть [этот сайт], где есть много полезных уроков и задач. Удачи!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос