Вопрос задан 16.06.2023 в 12:43. Предмет Информатика. Спрашивает Котова Полина.

Написать программу, которая в диапазоне от 1 до 100000 считает количество чисел, которые делятся на

8 без остатка. Помогите пожалуйста.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Громова Софья.

Ответ:

Python:

d = 0

for i in range(1,100000):

   if i%8==0:

       d += 1

print(d)

Pascal:

var

i: integer;

d: integer;

begin

d:=0;

for i:=1 to 100000 do begin

 if (i mod 8) = 0 then

 begin

  d := d + 1;

 end;

end;

writeln(d)

end.

Если есть вопросы, пиши

0 0
Отвечает Ковалёв Максим.

Ответ:

Объяснение:

Java: https://pastebin.com/vVy4BLiE

Python: https://pastebin.com/Pyt3WjaE

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Python, которая считает количество чисел в диапазоне от 1 до 100000, делящихся на 8 без остатка:

python
count = 0 # переменная для подсчета чисел, делящихся на 8 for num in range(1, 100001): if num % 8 == 0: count += 1 print("Количество чисел, делящихся на 8 без остатка:", count)

Программа использует цикл for, чтобы перебрать все числа в заданном диапазоне от 1 до 100000. Затем она проверяет, делится ли текущее число num на 8 без остатка с помощью оператора %. Если условие выполняется, то увеличиваем счетчик count на 1. В конце программы выводится количество найденных чисел, делящихся на 8 без остатка.

Выполнение программы может занять некоторое время, так как она проверяет каждое число в заданном диапазоне.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос