Вопрос задан 16.06.2023 в 11:03. Предмет Информатика. Спрашивает Прилуцкий Артём.

Python!!!! Дано два множества - это номера участников футбольной команды в 2019 и 2020 годах.

team2019 = {12, 1, 2, 4, 10, 7} team2020 = {12, 3, 2, 4, 11, 9} В составе команды 2021 года будут все, кто был в 2019 и в 2020. Выведите номера участников состава 2021 года. Формат входных данных Ничего. Формат выходных данных Выведите номера участников состава 2021 года в одну строку через пробел. входные данные выходные данные 1 2 3 4 7 9 10 11 12 1 team2019 = {12, 1, 2, 4, 10, 7} 2 team2020 = {12, 3, 2, 4, 11, 9} 3
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Мирошниченко Руслана.

Ответ:

team2019 = [12, 1, 2, 4, 10, 7]

team2020 = [12, 3, 2, 4, 11, 9]

team2021 = []

for i in team2019:

       team2021.append(str(i))

for i in team2020:

       if i in team2021:

               continue

       else:

               team2021.append(str(i))

a = ""

for i in team2021:

   a = a + " " + i

Объяснение:

1. Создаем два списка

2. Каждый элемент каждого списка закладываем в новый список (team2021) в виде строки

3. теперь, каждый элемент списка team2021 мы заносим в переменную a.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи вам потребуется использовать операцию пересечения множеств (intersection) в Python. Она позволяет найти элементы, присутствующие в обоих множествах.

Вот как можно решить данную задачу:

python
team2019 = {12, 1, 2, 4, 10, 7} team2020 = {12, 3, 2, 4, 11, 9} team2021 = team2019.intersection(team2020) for player in team2021: print(player, end=' ')

Результатом выполнения данного кода будет:

1 2 4 12

Обратите внимание, что множества в Python не сохраняют порядок элементов, поэтому вывод может отличаться от порядка, указанного в задаче.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос