Вопрос задан 16.06.2023 в 09:10. Предмет Информатика. Спрашивает Корниенко Борислав.

ПОМОГИТЕ ПОЖАЛУЙСТА 8КЛАСС НА ПИТОНЕ Напишите программу, которая получает с клавиатуры

натуральное число и определяет, сколько в его записи не четных цифр.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Выродов Максим.

Ответ:

a = int(input('Число: '))

s = 0 # здесь будет кол-во четных цифр

for i in list(str(a)): # превратил введённое число в строку, и эту строку сделал списком.

   if int(i)%2: s += 1 # проверяю есть ли остаток от деления у i-го числа, и если нет - то оно четное, если да,  прибовляю 1 к s

print("Количество нечетных цифр в введённом числе =", s)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на Python, которая получает натуральное число с клавиатуры и определяет, сколько нечетных цифр содержится в его записи:

```python number = int(input("Введите натуральное число: ")) count = 0

while number > 0: digit = number % 10 if digit % 2 != 0: count += 1 number //= 10

print("Количество нечетных цифр:", count) ```

В этой программе мы используем цикл `while`, чтобы последовательно получить каждую цифру числа. Затем мы проверяем, является ли цифра нечетной, и увеличиваем счетчик `count` при необходимости. В конце программы выводится количество нечетных цифр.

Например, если вы введете число 123456789, программа выведет:

``` Количество нечетных цифр: 5 ```

Примечание: В программе предполагается, что пользователь вводит только натуральные числа. Если нужно добавить проверку на натуральность числа, можно использовать условие `if number <= 0:`, чтобы выйти из программы или запросить ввод числа заново.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос