
ПОМОГИТЕЕЕЕ НА PASCAL!!!!! Дан массив из 20 элементов, заполненный случайными целыми числами из
интервала [-10, 10]. Выведите этот массив в строку и найдите наибольший элемент среди четных элементов массива

Ответы на вопрос

Программа:
Pascal:
const n = 20; // кол-во элементов в массиве
var
arr: array[1..n] of integer;
i, maxEven: integer;
begin
maxEven := -MAXINT; // для будущего поиска минимального числа
write('Массив: ');
for i := 1 to n do
begin
arr[i] := random(-10, 10); // заполнение случайными числами от -10 до 10
write(arr[i], ' '); // вывод элемента
if arr[i] mod 2 = 0 then // если число чётное, то...
maxEven := arr[i]; // установить значение переменной maxEven, равное текущему макс.элементу
end;
writeln(#13, 'Максимальный чётный элемент: ', maxEven);
end.



Для решения данной задачи на языке программирования Pascal, мы можем использовать следующий код:
```pascal program MaxEvenElement; var arr: array[1..20] of integer; i, maxEven: integer; begin // Заполняем массив случайными числами из интервала [-10, 10] Randomize; for i := 1 to 20 do begin arr[i] := Random(21) - 10; end;
// Выводим массив в строку for i := 1 to 20 do begin write(arr[i], ' '); end; writeln;
// Находим наибольший четный элемент массива maxEven := -11; // Минимальное значение для начала поиска for i := 1 to 20 do begin if (arr[i] mod 2 = 0) and (arr[i] > maxEven) then begin maxEven := arr[i]; end; end;
// Выводим наибольший четный элемент writeln('Наибольший четный элемент массива: ', maxEven); end. ```
В этом коде мы создаем массив из 20 элементов и заполняем его случайными целыми числами из интервала [-10, 10]. Затем мы выводим этот массив в строку и находим наибольший элемент среди четных элементов массива. Результат выводим на экран.
Надеюсь, этот пример поможет вам решить задачу на Pascal. Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili