Вопрос задан 12.04.2018 в 05:44.
Предмет Информатика.
Спрашивает Абдумежитова Дильнаваз.
Составьте программу определения количества четных и нечетных цифр в записи данного натурально числа
Ответы на вопрос
Отвечает Шорохов Андрей.
Var n,k1,k2:integer;
begin
write('n = ');
readln(n);
k1:=0; k2:=0;
while n>0 do
begin
if n mod 2=0 then k1:=k1+1 else k2:=k2+1;
n:=n div 10;
end;
writeln('Четных цифр - ',k1,', нечетных - ',k2);
end.
Пример:
n = 14568
Четных цифр - 3, нечетных - 2
Отвечает На Миша.
Program n1;
var a,kn,kh: longint;
begin
kn:=0;
kh:=0;
readln(a);
while a>0 do
begin
if (a mod 10) mod 2=0 then kh:=kh+1
else kn:=kn+1;
a:= a div 10;
end;
writeln('кол-во четных: ',kh);
writeln('нечетных: ',kn);
end.
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
