Вопрос задан 15.06.2023 в 20:21. Предмет Информатика. Спрашивает Зотеев Денис.

Ввод и вывод одномерного массива 1. Составить программу ввода и вывода массива: а) из 10-ти чётных

чисел: 2, 4, 6...; b) из 15-ти первых чисел, кратных числу 19; с) из 20-ти чисел: 1, 2, 1, 2...; d) 10-ти чисел: 1, 33, -5, 16, 0, 8, -17, 25, 44, 9; e) X = {11, 22, 33, 44, 55, 66, 77, 88, 99}; f) размера N> 1, степеней числа 2. ​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Смирнов Евгений.

Ответ:

Начнем с простого

d)

from array import *

x = array('i', [1, 33, -5, 16, 0, 8, -17, 25, 44, 9])

for i in x:

   print(i)

e)

from array import *

x=array('i')

for i in range(1,10):

   x.insert(i,i*11)

for i in x:

   print(i)

f)

from array import *

n=int(input())

x=array('i')

for i in range(1,n+1):

   x.insert(i,2**i)

for i in x:

   print(i)

a)

from array import *

n=10

x=array('i')

for i in range(1,n+1):

   x.insert(i,2*i)

for i in x:

   print(i)

b)

from array import *

n=15

x=array('i')

for i in range(1,n+1):

   x.insert(i,19*i)

for i in x:

   print(i)

c)

from array import *

n=20

x=array('i')

for i in range(2,n+2):

   x.insert(i,i%2+1)

for i in x:

   print(i)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Python, которая выполняет ввод и вывод указанных массивов:

а) Массив из 10-ти четных чисел:

python
array_a = [2*i for i in range(1, 11)] print(array_a)

б) Массив из 15-ти чисел, кратных числу 19:

python
array_b = [19*i for i in range(1, 16)] print(array_b)

с) Массив из 20-ти чисел: 1, 2, 1, 2...

python
array_c = [i % 2 + 1 for i in range(20)] print(array_c)

d) Массив из 10-ти чисел: 1, 33, -5, 16, 0, 8, -17, 25, 44, 9:

python
array_d = [1, 33, -5, 16, 0, 8, -17, 25, 44, 9] print(array_d)

e) Массив X = {11, 22, 33, 44, 55, 66, 77, 88, 99}:

python
array_e = [11*i for i in range(1, 10)] print(array_e)

f) Массив размера N > 1, степеней числа 2:

python
N = int(input("Введите размер массива: ")) array_f = [2**i for i in range(N)] print(array_f)

Вы можете запустить эту программу в среде разработки Python или воспользоваться онлайн-средой для выполнения кода на Python, чтобы увидеть результат.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос