Вопрос задан 15.06.2023 в 20:19. Предмет Информатика. Спрашивает Изосимова Элина.

Напишите программу, которая задумывает три целых рандомных числа, далее пользователь вводит одно

значение с клавиатуры. Если он угадал одно из трех чисел то вывести сообщение «вы выиграли» иначе «вы проиграли».
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Колосов Дмитрий.

Відповідь:

import random

L=[]

for _ in range(3):

   L.append(random.randint(0,100))

F=int(input("Попробуйте угадать одно из трёх числе в промежутке от 0 до 100:\n"))

print("вы выиграли") if F==L[0] or F==L[1] or F==L[2] else print("вы проиграли")

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь вам с написанием программы на Python, которая делает то, что вы просите. Вот один из возможных вариантов решения:

```python # Импортируем модуль random для генерации случайных чисел import random

# Задумываем три разных целых числа от 1 до 10 numbers = random.sample(range(1, 11), 3)

# Выводим подсказку для пользователя print("Я загадал три разных целых числа от 1 до 10. Попробуйте угадать одно из них.")

# Запрашиваем ввод от пользователя и преобразуем его в целое число user_input = int(input("Введите ваше число: "))

# Проверяем, есть ли введенное число среди загаданных if user_input in numbers: # Если да, то поздравляем пользователя с победой print("Вы выиграли! Вы угадали одно из чисел:", user_input) else: # Если нет, то сообщаем пользователю о проигрыше и показываем загаданные числа print("Вы проиграли. Вы не угадали ни одного из чисел.") print("Загаданные числа были:", numbers) ```

Вы можете запустить эту программу в онлайн-редакторе или в своей среде разработки. Для получения дополнительной информации о том, как работать с пользовательским вводом в Python, вы можете посмотреть эти ресурсы.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос