
Помогите пожалуйста написать программу в C++ Напишите класс, который принимает с клавиатуры
оценку ученика(целое число) и проверяет не является ли введённое значение ошибочным.На экран должно выводиться соответствующее текстовое сообщение.

Ответы на вопрос

Ответ:
#include <iostream>
// Бесполезная абстракция:
class GradeChecker
{
public:
GradeChecker() {
int grade{};
std::cin >> grade;
if (grade >= 2 && grade <= 5) {
std::cout << "Everything is right: " << grade << std::endl;
}
else {
std::cout << "Grade should be in [2;5] interval" << std::endl;
}
}
};



Конечно! Вот пример программы на C++, которая реализует описанный класс:
cpp#include <iostream>
class StudentGradeValidator {
private:
int grade;
public:
void inputGrade() {
std::cout << "Введите оценку ученика: ";
std::cin >> grade;
}
void validateGrade() {
if (grade >= 1 && grade <= 5) {
std::cout << "Введенная оценка корректна." << std::endl;
} else {
std::cout << "Ошибка! Введенная оценка некорректна." << std::endl;
}
}
};
int main() {
StudentGradeValidator validator;
validator.inputGrade();
validator.validateGrade();
return 0;
}
В этой программе создается класс StudentGradeValidator
, который содержит приватное поле grade
для хранения оценки ученика. Метод inputGrade()
запрашивает у пользователя ввод оценки, а метод validateGrade()
проверяет, является ли введенное значение корректным (от 1 до 5) и выводит соответствующее сообщение на экран.
В функции main()
создается экземпляр класса StudentGradeValidator
, вызывается метод inputGrade()
для ввода оценки и затем вызывается метод validateGrade()
для проверки и вывода сообщения.
Надеюсь, это поможет! Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili