Вопрос задан 15.06.2023 в 17:43. Предмет Информатика. Спрашивает Петюль Илья.

РЕШИТЬ НА ПИТОНЕ С ЦИКЛОМ "Лена быстро решила контрольную. Чтобы не скучать, она достала

фломастеры и стала рисовать узоры из символов s. В первой строке она нарисовала один символ s, во второй — два символа s, а в n-й строке — n символов s. Дано число n и символ s. Выведи узор, который получился у Лены. Ввод: в первой строке вводится число(количество строк, например, 3) , во второй - символ (например, +). Вывод + ++ +++
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шихалев Дима.

n = int(input())

s = input()

for i in range(1, n + 1):

   print(s*i)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете решить эту задачу на Python с использованием цикла for. Вот пример кода, который решает эту задачу:

python
n = int(input("Введите число строк: ")) s = input("Введите символ: ") pattern = "" for i in range(1, n + 1): pattern += s * i if i != n: pattern += " " print(pattern)

В этом коде мы сначала запрашиваем у пользователя число строк n и символ s. Затем мы инициализируем переменную pattern пустой строкой.

Затем мы используем цикл for, который итерируется от 1 до n + 1. На каждой итерации мы добавляем i повторений символа s к переменной pattern. Затем мы добавляем пробел (" ") к pattern, за исключением последней строки.

Наконец, мы выводим полученный узор, хранящийся в переменной pattern.

Пример ввода и вывода:

diff
Введите число строк: 3 Введите символ: + + ++ +++

Надеюсь, это поможет вам решить задачу!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос