
Составьте программу на Паскале. Распечатать квадраты 10ти чисел, вводимых с клавиатуры


Ответы на вопрос

Ответ:
Var
i,n: Integer;
BEGIN
Writeln('Введите 10 чисел: ');
For i:=1 to 10 do
begin
Readln(n);
Writeln(' ',n,'^2=',Sqr(n));
end;
END.
Объяснение:
взято с форума; где "Writeln()" пиши так, как пишите обычно



Конечно! Вот пример программы на Паскале, которая печатает квадраты 10 чисел, вводимых с клавиатуры:
```pascal program PrintSquares; var i, num: integer; begin for i := 1 to 10 do begin write('Введите число: '); readln(num); writeln('Квадрат числа ', num, ' равен ', num * num); end; end. ```
В этой программе мы используем цикл `for` для повторения действий 10 раз. На каждой итерации цикла мы запрашиваем у пользователя число с помощью `readln`, а затем выводим квадрат этого числа с помощью `writeln`.
Примечание: Программа предполагает, что пользователь будет вводить только целые числа. Если вам нужно обрабатывать вещественные числа или проверять ввод на корректность, вам может потребоваться добавить соответствующую логику в программу.
Надеюсь, это поможет! Если у вас есть еще вопросы, не стесняйтесь задавать.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili