Напишите программу которая в зависимости от номера месяца выводит название времени года Помагите
пжОтветы на вопрос
Відповідь:
using namespace std;
int main()
{
setlocale (LC_ALL, "rus");
int n;
cout << "Номер месяца: "; cin >> n;
switch (n) {
case 12: case 1: case 2:
cout << "Зима\n";
break;
case 3: case 4: case 5:
cout << "Весна\n";
break;
case 6: case 7: case 8:
cout << "Лето\n";
break;
case 9: case 10: case 11:
cout << "Осень\n";
break;
default:
cout << "Ошибочный номер месяца!\n";
}
Пояснення:
Конечно, вот пример программы на языке Python, которая будет выводить название времени года в зависимости от введенного номера месяца:
pythonmonth = int(input("Введите номер месяца (от 1 до 12): "))
if month == 12 or month == 1 or month == 2:
season = "зима"
elif month == 3 or month == 4 or month == 5:
season = "весна"
elif month == 6 or month == 7 or month == 8:
season = "лето"
elif month == 9 or month == 10 or month == 11:
season = "осень"
else:
season = "неправильный номер месяца"
print(f"Время года: {season}")
После запуска программы она запросит у вас ввести номер месяца. В ответ будет выведено название времени года, соответствующего введенному номеру месяца. Например, для ввода числа 3 будет выведено "Время года: весна".
Похожие вопросы
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
