Вопрос задан 15.06.2023 в 07:54. Предмет Информатика. Спрашивает Абдуллаева Эдие.

СРОНО ДАЮ 50 БАЛЛОВ!!!!!!!!! Напишите программу которая в последовательно натуральных чисел

определяет количество честных трёх значных чисел программа получает на ввод натуральные числа количество введённых чисел не известно последовательность чисел заканчивается числом 0.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сова Аня.

Ответ:

s = int(input())

k = 0

while s != 0:

   if len(str(s)) == 3 and s % 2 == 0:

       k += 1

   s = int(input())

print(k)

Объяснение:

В условии написано "честных", но я так понял имеется в виду "чётных". Если верно, то отметь, пожалуйста, как лучший ответ.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа для определения количества трёхзначных чисел:

Для создания программы, которая определяет количество трёхзначных чисел в последовательности натуральных чисел, можно использовать следующий код на Python:

```python count = 0 # Инициализация счетчика честных трёхзначных чисел

while True: num = int(input("Введите натуральное число (для завершения введите 0): ")) if num == 0: break # Прерываем цикл при вводе 0 if 100 <= num <= 999: count += 1 # Увеличиваем счетчик, если число трёхзначное

print(f"Количество трёхзначных чисел: {count}") ```

Этот код позволяет пользователю последовательно вводить натуральные числа, и программа определяет количество трёхзначных чисел в этой последовательности. Когда пользователь вводит 0, программа завершает выполнение и выводит количество трёхзначных чисел.

Надеюсь, этот код поможет вам решить задачу! Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос