Вопрос задан 15.06.2023 в 07:33.
Предмет Информатика.
Спрашивает Скульский Матвей.
Задача №112168. Точка - 4 Напишите программу, которая определяет, попала ли точка с заданными
координатами в заштрихованную область. Входные данные Входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x -координата, затем – y -координата). Выходные данные Программа должна вывести слово 'YES', если точка попала в заштрихованную область, и слово 'NO', если не попала. Примеры входные данные 0. 1. выходные данные NO входные данные 0. -1. выходные данные YES
Ответы на вопрос
Отвечает Зозуля Никита.
#include <iostream>
using namespace std;
int main() {
double x, y;
cin >> x >> y;
if (y >= x * x - 2 && (y <= x || y <= -x))
cout << "YES";
else
cout << "NO";
}
Похожие вопросы
Информатика 95
Информатика 27
Информатика 195
Информатика 316
Информатика 189
Информатика 108
Информатика 191
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
