Вопрос задан 14.06.2023 в 18:59. Предмет Информатика. Спрашивает Бондаренко Александра.

Решение нужно в ПИТОНЕ 15.2 Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, оканчивающихся на 3. Программа получает на вход количество чисел в последовательности, а затем сани числа. В последовательности всегда имеется число, оканчивающееся на 3. Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число — количество чисел, оканчивающихся на 3. Пример работы программы: Входные данные выходные данные 3 13 23 2 24 Источник: ГИА
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Савчук Анастасия.

Ответ:

def convertToInt(str: str) -> int:

   try:

       return int(str)

   except Exception:

       exit()

def main() -> None:

   lenNumberArray = convertToInt (

       input(

           "количество чисел: "

       )

   )

   #условия  Количество чисел не превышает 1000

   if not(0 < lenNumberArray < 1000):

       exit()

   numbers = [

       input(

           f"число {i+1}: "

       ) for i in range(lenNumberArray)

   ]

   howNumberEnd3 = 0

   for i in numbers:

       #условие Введенные числа не превышают 30 000.

       if convertToInt(i) > 30000:

           exit()

       

       if i.replace(" ", "")[-1] == "3":

           howNumberEnd3 += 1

   #Программа должна вывести одно число — количество чисел, оканчивающихся на 3.

   print(f"чисел которие заканчиваются на 3: {howNumberEnd3}")

if __name__ == "__main__":

   main()

Объяснение:

примерчик

>>> python main.py

количество чисел: 5

число 1: 3

число 2: 13

число 3: 23

число 4: 2

число 5: 24

чисел которие заканчиваются на 3: 3

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот решение на языке Python для задачи, которую вы описали:

python
count = int(input("Введите количество чисел: ")) ending_with_3 = 0 for _ in range(count): number = int(input("Введите число: ")) if number % 10 == 3: ending_with_3 += 1 print("Количество чисел, оканчивающихся на 3:", ending_with_3)

Эта программа запрашивает у пользователя количество чисел в последовательности (count), а затем последовательно запрашивает каждое число и проверяет, оканчивается ли оно на 3. Если число оканчивается на 3, то переменная ending_with_3 увеличивается на 1. По завершении цикла выводится количество чисел, оканчивающихся на 3.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос