Вопрос задан 14.06.2023 в 03:27.
Предмет Информатика.
Спрашивает Аманбаева Асемай.
Даю 25 балов! срочно! Напишите программу (на паскале), которая находит: сумму, произведение и
среднее арифметическое (количество знаков после точки должно быть равно 3) трёх целых чисел, введённых с клавиатуры. Например, при вводе чисел 4, 5 и 7 мы должны получить ответ 4+5+7=16, 4*5*7=140, (4+5+7)/3=5.333Ответы на вопрос
Отвечает Литвинов Артур.
Ответ:
program programm;
var x,y,z,Sum,Mult:integer;
Arif:real;
begin
Readln(x,y,z);
Sum:=x+y+z;
Mult:=x*y*z;
Arif:=(x+y+z)/3;
Writeln(Sum);
Writeln(Mult);
Writeln(Arif:0:3);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Pascal, которая выполняет указанные вычисления:
pascalprogram Calculation; var num1, num2, num3: integer; sum, product, average: real; begin writeln('Введите три целых числа:'); readln(num1, num2, num3); sum := num1 + num2 + num3; product := num1 * num2 * num3; average := sum / 3; writeln('Сумма: ', sum:0:3); writeln('Произведение: ', product:0:3); writeln('Среднее арифметическое: ', average:0:3); readln; end.
Программа запрашивает у пользователя ввод трех целых чисел, затем вычисляет сумму, произведение и среднее арифметическое этих чисел. Затем результаты выводятся на экран с требуемым количеством знаков после точки.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
