Вопрос задан 12.06.2023 в 09:52. Предмет Информатика. Спрашивает Иванов Ванек.

Массив содержит информацию о возрасте 20 участников соревнований. составьте программу, определяющую

возраст самого молодого участника. срочно нужно на завтра, буду очень благодарна и помолюсь на ваше здоровье.вот пример написания программ:​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гайнигалимов Данис.

Ответ:

program z;

var

 v: array [1..20] of integer;

 minv: integer;

begin

 for var i := 1 to 20 do

 begin

   v[i] := random(22) + 7; //задание возраста участников

   write(v[i], ' '); // вывод возраста участников на экран

 end;

 writeln; //переход на новую строку

 minv := v[1]; //начальное значение возраста самого молодого участника

 for var i := 2 to 20 do if v[i] < minv then minv := v[i]; //новое значение переменной minv

 writeln('Возраст самого молодого участника = ', minv);

end.

Объяснение:

v: array [1..20] of integer; - массив, для сохранения данных о возрасте (полных лет) 20 участников

для работы с массивом используем цикл со счётчиком (for)

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос