Вопрос задан 10.06.2023 в 08:20. Предмет Информатика. Спрашивает Курилов Стефан.

Помогите, пожалуйста, с написанием программы. (Python) Ограничение времени 1 секундаОграничение

памяти 64MbВвод стандартный вводВывод стандартный выводВсе очень просто. Если у вас есть знакомая ведьма, в особенности, довольная ведьма, то вам крупно повезло. Помните, если вы повстречали невысокую, крепко сбитую ведьму, следует предложить ей обед, ну, или, на худой конец, пару лепешек. Это принесет вам счастье.Напишите программу, которая определит, когда следует ожидать наступления счастья после встречи с ведьмой в зависимости от величины того, что вы ей предложилиФормат вводаИсходная дата в формате YYYY/MM/DD.Величина подношения – целое число.Количество дней, которые нужно определить.Формат вывода. Выводится требуемое количество дней в виде, показанном в примерах, каждое с новой строки.Дни определяются так: это не может быть суббота или воскресенье, в эти дни и так неплохо. Чем больше подношение, тем быстрее должно наступить счастье, поэтому количество дней ожидания равно 100 // подношение. Подходящий день наступает не раньше, чем истечет время ожидания.Пример 1Ввод: 2021/02/2363 Вывод:Thu 11 MarFri 12 MarMon 15 MarПример 2Ввод: 2021/05/17105Вывод:Thu 27 MayFri 28 MayMon 31 MayTue 01 JunWed 02 Jun
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Орлова Соня.

Відповідь:

import datetime

date_str, offering, num_days = input().split()

offering = int(offering)

num_days = int(num_days)

date = datetime.datetime.strptime(date_str, '%Y/%m/%d')

days_wait = 100 // offering

current_day = 1

while num_days > 0:

   if date.weekday() not in [5, 6]:

       if current_day >= days_wait:

           print(date.strftime('%a %d %b'))

           num_days -= 1

       current_day += 1

   date += datetime.timedelta(days=1)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Python, которая решает данную задачу:

python
import datetime def find_happiness_date(start_date, offering, num_days): start_date = datetime.datetime.strptime(start_date, "%Y/%m/%d") days_to_wait = 100 // offering current_date = start_date output_dates = [] while len(output_dates) < num_days: if current_date.weekday() < 5: # Проверка, что это не суббота или воскресенье output_dates.append(current_date.strftime("%a %d %b")) current_date += datetime.timedelta(days=1) if (current_date - start_date).days >= days_to_wait: current_date += datetime.timedelta(days=days_to_wait) return output_dates # Чтение вводных данных start_date, offering, num_days = input().split() num_days = int(num_days) # Поиск дат счастья happiness_dates = find_happiness_date(start_date, int(offering), num_days) # Вывод результатов for date in happiness_dates: print(date)

Вы можете ввести данные в формате, указанном в примерах, и программа выдаст требуемое количество дней.

0 0

Последние заданные вопросы в категории Информатика

Задать вопрос