 
дан одномерный массив размерностью 5 элементы массива это целые числа из промежутка [0;50].
Напишите программу вычисляющую сумму элементов массива которые больше 4 и кратны 6 (PASCAL) 0
        0
         0
        0
    Ответы на вопрос
 
        Ответ:
Объяснение:
var
  array: array[1..5] of integer;
  sum, i: integer;
begin
  array[1] := 10;
  array[2] := 15;
  array[3] := 20;
  array[4] := 25;
  array[5] := 30;
  sum := 0;
  for i := 1 to 5 do
    begin
      if (array[i] > 4) and (array[i] mod 6 = 0) then
        begin
          sum := sum + array[i];
        end;
    end;
  writeln(sum);
end.
 0
                    0
                     0
                    0
                 
            Конечно! Вот пример программы на Pascal, которая вычисляет сумму элементов одномерного массива, которые больше 4 и кратны 6:
pascalprogram SumArrayElements; const N = 5; var arr: array[1..N] of Integer; i, sum: Integer; begin sum := 0; // Заполнение массива случайными числами от 0 до 50 Randomize; for i := 1 to N do arr[i] := Random(51); // Вычисление суммы элементов, больших 4 и кратных 6 for i := 1 to N do begin if (arr[i] > 4) and (arr[i] mod 6 = 0) then sum := sum + arr[i]; end; // Вывод суммы на экран Writeln('Сумма элементов массива, больших 4 и кратных 6: ', sum); // Ожидание ввода перед закрытием окна консоли Readln; end.
Программа создает массив arr размерностью 5 и заполняет его случайными числами от 0 до 50. Затем она проходит по элементам массива и проверяет, больше ли каждый элемент 4 и кратен ли он 6. Если условие выполняется, то значение элемента добавляется к переменной sum. В конце программа выводит полученную сумму на экран.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			