Помогите, пожалуйста. Написать программу в С. Сформулируйте динамічний одновимірний масив, у
якому 15 елементів, заповніть його випадковими числами та виведіть на друк. Оформіть генерацію і виведення масиву за допомогою функції користувача. Реалізуйте цю програму за допомогою операцій new та delete. Ответы на вопрос
1. Створіть функцію для генерації масиву випадкових чисел.
2. Створіть функцію для виведення масиву на екран.
3. Створіть функцію main, яка буде викликати функції для генерації та виведення масиву.
4. Використовуйте оператор new для створення динамічного масиву.
5. Використовуйте оператор delete для звільнення пам'яті, виділеної для масиву.
Ось приблизний код для генерації масиву випадкових чисел:
c++
#include <iostream>
#include <cstdlib>
#include <ctime>
using namespace std;
void generateArray(int *arr, int size) {
srand(time(NULL)); // ініціалізуємо генератор випадкових чисел
for (int i = 0; i < size; i++) {
arr[i] = rand() % 100; // генеруємо числа в діапазоні 0-99
}
}
void printArray(int *arr, int size) {
for (int i = 0; i < size; i++) {
cout << arr[i] << " ";
}
cout << endl;
}
int main() {
int size = 15;
int *arr = new int[size]; // створюємо динамічний масив
generateArray(arr, size); // заповнюємо масив випадковими числами
printArray(arr, size); // виводимо масив на екран
delete[] arr; // звільняємо пам'ять, виділену для масиву
return 0;
}
Звучити, дякую, що звернулися за допомогою. Ось приклад програми на C++, що задовольняє вашим вимогам:
cpp#include <iostream>
#include <cstdlib> // Для функції rand()
#include <ctime> // Для функції time()
// Функція для генерації та виведення масиву
void generateAndPrintArray(int size) {
// Створення динамічного масиву
int* array = new int[size];
// Заповнення масиву випадковими числами
for (int i = 0; i < size; i++) {
array[i] = rand() % 100; // Генеруємо число від 0 до 99
}
// Виведення масиву на друк
for (int i = 0; i < size; i++) {
std::cout << array[i] << " ";
}
// Видалення динамічного масиву
delete[] array;
}
int main() {
// Ініціалізація генератора випадкових чисел
srand(time(NULL));
// Виклик функції для генерації та виведення масиву
generateAndPrintArray(15);
return 0;
}
У цій програмі ми створюємо функцію generateAndPrintArray, яка отримує розмір масиву як параметр. Всередині функції ми створюємо динамічний масив за допомогою оператора new, заповнюємо його випадковими числами та виводимо на друк. Після цього ми видаляємо динамічний масив за допомогою оператора delete[].
У функції main ми ініціалізуємо генератор випадкових чисел, викликаємо функцію generateAndPrintArray з розміром 15 та повертаємо 0.
Запустіть цей код у вашому середовищі розробки C++ і ви отримаєте випадковий масив з 15 елементів, виведений на екран.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
