Вопрос задан 30.04.2023 в 21:17.
Предмет Информатика.
Спрашивает Деревня Горная.
Помогите написать программу ( Pascal ABC) Программирование циклических алгоритмов. Дано натуральное
число N. Вычислить S=1+1/3+1/5+1/7+...+1/2N+1Ответы на вопрос
Отвечает Барышников Диман.
var n,i:integer; s:real;
begin
readln(n);
s:=0;
for i:=0 to n do s:=s+1/(2*i+1);
writeln('s = ',s);
end.
Пример:
5
s = 1.878210678210678e+00
0
0
begin
readln(n);
s:=0;
for i:=0 to n do s:=s+1/(2*i+1);
writeln('s = ',s);
end.
Пример:
5
s = 1.878210678210678e+00
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
var
N: integer;
S, i: real;
begin
write('Введите натуральное число N: ');
readln(N);
S := 0;
for i := 1 to 2*N+1 do
if i mod 2 <> 0 then // если i — нечетное число
S := S + 1/i; // прибавляем 1/i к сумме
writeln('Сумма ряда равна: ', S);
end.
0
0
N: integer;
S, i: real;
begin
write('Введите натуральное число N: ');
readln(N);
S := 0;
for i := 1 to 2*N+1 do
if i mod 2 <> 0 then // если i — нечетное число
S := S + 1/i; // прибавляем 1/i к сумме
writeln('Сумма ряда равна: ', S);
end.
Топ вопросов за вчера в категории Информатика
Информатика 20
Информатика 23
Информатика 21
Информатика 29
Информатика 21
Информатика 20
Информатика 26
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
