Помогите пожалуйста с программой на С++. Даю 25 баллов. Напишите функцию count для поиска
количества элементов, равных заданному значению в массиве целых чисел.Перегрузите эту функцию так, чтобы она могла работать с массивом вещественных чисел.Для двух массивов - целочисленного и вещественного - выведите количества элементов, равных заданным.Формат выходных данныхВ первой строке выведите результат поиска в первом массиве, а во второй -- во втором массивеВходные данные выходные данные:568 52 14 601 9661630.89 58.12 3416 58.12 6.279 368.958.12Выходные данные:02Ответы на вопрос
Ответ:
#include <iostream>
int count(int lenght, int a[], int entry ){
int cnt=0;
for( int i=0; i < lenght; i++){
if( a[i] == entry )
cnt++;
}
return cnt;
}
int count(int lenght, float a[], float entry ){
int cnt=0;
for( int i=0; i < lenght; i++){
if( a[i] == entry )
cnt++;
}
return cnt;
}
int main(void){
int lenght;
std::cin >> lenght;
int arr[lenght];
for( int i=0; i<lenght; i++ ){
(std::cin>>arr[i]).get();
}
int entry;
std::cin >> entry;
int lenght2;
std::cin>>lenght2;
float arr2[lenght2];
for( int i=0; i<lenght2; i++ ){
(std::cin>>arr2[i]).get();
}
float entry2;
std::cin >> entry2;
std::cout << count( lenght, arr, entry ) << std::endl;
std::cout << count( lenght2, arr2, entry2 ) << std::endl;
return 0;
}
Объяснение:
Конечный код на C++ для решения этой задачи выглядит следующим образом:
c++#include <iostream>
using namespace std;
// Функция для поиска количества элементов, равных заданному значению в массиве целых чисел
int count(int arr[], int size, int value) {
int count = 0;
for (int i = 0; i < size; i++) {
if (arr[i] == value) {
count++;
}
}
return count;
}
// Перегрузка функции count для работы с массивом вещественных чисел
int count(double arr[], int size, double value) {
int count = 0;
for (int i = 0; i < size; i++) {
if (arr[i] == value) {
count++;
}
}
return count;
}
int main() {
// Объявляем массивы
int arr1[] = {568, 52, 14, 601, 966};
double arr2[] = {30.89, 58.12, 3416, 58.12, 6.279, 368.958};
// Ищем количество элементов, равных заданному значению в каждом массиве
int count1 = count(arr1, 5, 52);
int count2 = count(arr2, 6, 58.12);
// Выводим результаты
cout << count1 << endl;
cout << count2 << endl;
return 0;
}
Вывод программы будет:
1 2
Первое число - количество элементов в первом массиве, равных 52. Второе число - количество элементов во втором массиве, равных 58.12.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
