Вопрос задан 03.05.2021 в 07:52. Предмет Информатика. Спрашивает Холмс Дарина.

Ребят, помогите с задачей. Напишите программу подсчёта суммы всех отрицательных элементов заданного

целочисленного массива размером 30 элементов. Если отрицательных элементов нет, то сообщить об этом) p.s. В паскале
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Стрисюк Віталіна.
Var
  n, i, s, k:integer;
  a:array [1..30] of integer;
begin
  writeln('Vvedite massiv');
  for i:=1 to 30 do
  readln(a[i]);
  writeln('Massiv');
  for i:=1 to 30 do
  write(a[i],' ');
  writeln();
  k:=0; s:=0;
  for i:=1 to 30 do
  if a[i]<0 then
  begin
  s:=a[i]+s;
  k:=1;
  end;
  if k=1 then
  writeln('Summa otricatelnih elementov: ',s)
  else
  writeln('Otricatelnih elementov net');
  readln();   
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь! Вот пример программы на Pascal, которая решает задачу подсчета суммы отрицательных элементов целочисленного массива:

php
program SumNegativeElements; const ARRAY_SIZE = 30; // размер массива var arr: array [1..ARRAY_SIZE] of integer; // объявляем массив sum: integer; // переменная для хранения суммы отрицательных элементов i: integer; // переменная для итерации по массиву begin // Заполнение массива случайными числами в диапазоне от -50 до 50 randomize; for i := 1 to ARRAY_SIZE do arr[i] := random(101) - 50; // Подсчет суммы отрицательных элементов массива sum := 0; for i := 1 to ARRAY_SIZE do if arr[i] < 0 then sum := sum + arr[i]; // Вывод результата if sum = 0 then writeln('Отрицательных элементов в массиве нет') else writeln('Сумма отрицательных элементов: ', sum); readln; end.

Как работает программа:

  1. Определяем константу ARRAY_SIZE, которая содержит размер массива (в данном случае, 30 элементов).

  2. Объявляем массив arr размером ARRAY_SIZE.

  3. Генерируем случайные числа от -50 до 50 и заполняем ими массив arr.

  4. Объявляем переменную sum для хранения суммы отрицательных элементов и переменную i для итерации по массиву.

  5. Проходим циклом по массиву и суммируем все отрицательные элементы в переменную sum.

  6. Если sum равна нулю, выводим сообщение "Отрицательных элементов в массиве нет", иначе выводим сообщение "Сумма отрицательных элементов: " и значение переменной sum.

  7. Ждем, пока пользователь нажмет любую клавишу, чтобы закрыть программу.

Надеюсь, это поможет!

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос