Вопрос задан 02.05.2021 в 16:58.
Предмет Информатика.
Спрашивает Музалевский Александр.
Написать задачи на языке Pascal: 1. Возвести число в квадрат.2. Даны три числа. Найти среднее
арифметическое трех чисел.3. Найти значение выражения y=8*x(лучше чтобы это работало на Linux)Ответы на вопрос
Отвечает Малахова Ксения.
Ответ: Компилятор PascalABC.NET
1) var a,v: integer;
begin
writeln('a'); readln(a); v:=a*a;
writeln(v); end.
2) var a,b,c, v: real;
begin
writeln('a'); readln(a);writeln('b'); readln(b);writeln('c'); readln(c);
v:=(a+b+c)/3;
writeln(v); end.
3)var v,y: integer;
begin
writeln('y'); readln(y); v:=8*y;
writeln(v); end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
- Написать программу, которая возводит число в квадрат:
sqlprogram Square;
var
num, result: integer;
begin
write('Введите число: ');
readln(num);
result := num * num;
writeln('Квадрат числа ', num, ' = ', result);
end.
- Написать программу, которая находит среднее арифметическое трех чисел:
scssprogram Average;
var
num1, num2, num3: integer;
average: real;
begin
write('Введите первое число: ');
readln(num1);
write('Введите второе число: ');
readln(num2);
write('Введите третье число: ');
readln(num3);
average := (num1 + num2 + num3) / 3;
writeln('Среднее арифметическое чисел ', num1, ', ', num2, ' и ', num3, ' = ', average);
end.
- Написать программу, которая находит значение выражения y = 8 * x:
arduinoprogram Expression;
var
x, y: integer;
begin
write('Введите значение x: ');
readln(x);
y := 8 * x;
writeln('Значение выражения y = 8 * ', x, ' = ', y);
end.
Эти программы могут быть скомпилированы и запущены на операционной системе Linux, если установлен компилятор языка Pascal (например, Free Pascal) и настроена среда разработки (например, Lazarus).
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
