
Вопрос задан 02.05.2021 в 09:47.
Предмет Информатика.
Спрашивает Косотуров Кирилл.
Напишите программу подсчета суммы и произведения цифр для данного целого двузначного числа.
Используйте пригласительную строку. Используйте процедуру очистки экрана (для ТП). Установите формат вывода данных:6 позиций для всего числа, 2 позиции - для доробной части. Дополнительно: напишите программу, которая меняет местами цифры в целом двузначном числе. Например: Входные данные: 35 Результат:53

Ответы на вопрос

Отвечает Асланов Мухаммед.
1)
uses crt;
var chislo,summa,proiz:integer;
begin
clrscr;
Readln(chislo);
summa:=(chislo div 10) + (chislo mod 10);
proiz:=(chislo div 10) * (chislo mod 10);
Writeln(' сумма:',summa:6:2);
Writeln(' произведения :',proiz:6:2);
end.
2)
var chislo:integer;
begin
Readln(chislo);
chislo:=(chislo div 10)+(chislo mod 10)*10;
Writeln(chislo);
end.
uses crt;
var chislo,summa,proiz:integer;
begin
clrscr;
Readln(chislo);
summa:=(chislo div 10) + (chislo mod 10);
proiz:=(chislo div 10) * (chislo mod 10);
Writeln(' сумма:',summa:6:2);
Writeln(' произведения :',proiz:6:2);
end.
2)
var chislo:integer;
begin
Readln(chislo);
chislo:=(chislo div 10)+(chislo mod 10)*10;
Writeln(chislo);
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Какую именно программу Вы хотите написать? Вам нужна программа на каком-то конкретном языке программирования?


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili