Вопрос задан 01.05.2021 в 08:25.
Предмет Информатика.
Спрашивает Смирнов Евгений.
Написать программу, которая предлагает пользователю ввести число и, затем подсчитывает, сколько раз
это число встречается в массиве. с++Ответы на вопрос
Отвечает Крапивин Александр.
Т.к. части кода могут удалиться при загрузке ответа, ниже фото с кодом

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечное решение зависит от того, какой тип данных будет использоваться в массиве и сколько элементов он будет содержать. Вот пример кода на C++, который решает эту задачу для целочисленного массива:
c++#include <iostream>
using namespace std;
int main() {
int arr[] = {1, 2, 3, 4, 5, 3, 6, 7, 8, 3}; // исходный массив
int n = sizeof(arr) / sizeof(arr[0]); // количество элементов в массиве
int num, count = 0;
cout << "Введите число для поиска: ";
cin >> num;
for (int i = 0; i < n; i++) {
if (arr[i] == num) {
count++;
}
}
cout << "Число " << num << " встречается в массиве " << count << " раз." << endl;
return 0;
}
В этом коде мы инициализируем исходный массив arr и определяем количество его элементов n. Затем мы запрашиваем у пользователя число для поиска num. Затем мы перебираем каждый элемент в массиве и увеличиваем переменную count, если текущий элемент равен числу для поиска num. Наконец, мы выводим количество вхождений num в массиве на экран.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
