 
Вопрос задан 01.05.2021 в 06:21.
Предмет Информатика.
Спрашивает Мисик Юля.
Написание программы на языке C++ Здравствуйте, помогите пожалуйста написать программу. Задание:
составьте программу которая вводит символы до знака $. Пусть программа считает число введённых точек и выведет подсчитанное количество на экран монитора. Пожалуйста помогите. Написано было в визуал Студио 2015 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Вишня Ева.
                
    Привет, я тестировал на VS 2017, но разницы нет, я тебя уверяю (по крайней мере в данном случае).
Кратко об моём решении. Запускаю цикл и считываю символ в переменную, если это точка, добавляю к счётчику +1, если доллар - цикл прекращается.
Мой вариант решения:
#include <iostream>
using namespace std;
int main()
{
char symbol;
int counter = 0;
do
{
cout << "Enter symbol -> ";
cin >> symbol;
if (symbol == '.') counter++;
} while (symbol != '$');
cout << "Dot's counter " << counter << endl;
cin.get();
cin.get();
}
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно, я могу помочь в написании программы на языке C++. Вот готовый код для решения вашей задачи:
c++#include <iostream>
using namespace std;
int main()
{
    char ch;
    int count = 0;
    
    cout << "Введите символы, закончив ввод знаком $\n";
    
    do
    {
        cin.get(ch);
        if (ch == '.')
            count++;
    } while (ch != '$');
    
    cout << "Количество точек: " << count << endl;
    
    return 0;
}
Как работает программа:
- Объявляем переменные chиcount.chиспользуется для чтения символов, аcountиспользуется для подсчета количества точек.
- Выводим сообщение с инструкцией для пользователя.
- Запускаем цикл do-while, который будет продолжаться до тех пор, пока не будет введен знак$.
- В каждой итерации цикла считываем символ и проверяем, является ли он точкой. Если да, увеличиваем счетчик count.
- После того, как пользователь ввел знак $, выводим количество точек на экран.
- Завершаем программу.
Надеюсь, это поможет! Если у вас есть какие-либо вопросы, не стесняйтесь спрашивать.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			