Вопрос задан 29.04.2021 в 03:57.
Предмет Информатика.
Спрашивает Ахметов Мирас.
Составить программу по условию: дан массив из 10 элементов.Найти сумму элементов, кратных 3 и
двузначных. Массив задан случайно на паскалеОтветы на вопрос
Отвечает Романенко Максим.
Так как задание не формализовано выводит последовательно суммы кратных 3 и двухзначных чисел
Program TZ5;
const
n=10;
var
a:array [1..n] of integer;
i,b:integer;
begin
randomize;
for i:=1 to n do begin
a[i]:=random (20);
a[i]:=a[i]-10;
writeln(i,' ',a[i]);
end;
b:=0;
for i:=1 to n do
if (a[i] mod 3)=0 then
b:=b+a[i];
writeln('summa kratnyh 3m=',b);
b:=0;
for i:=1 to n do
if abs(a[i]) >9 then b:=b+a[i];
writeln('summa dvuhznachnyh =',b);
readln;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Привет! Вот программа на языке Pascal, которая решает задачу:
lessprogram SumOfMultiples;
var
arr: array[1..10] of integer; // объявляем массив из 10 элементов
i, sum: integer;
begin
randomize; // инициализируем генератор случайных чисел
// заполняем массив случайными числами от 10 до 99
for i := 1 to 10 do
arr[i] := random(90) + 10;
sum := 0; // инициализируем сумму нулем
// считаем сумму элементов, кратных 3 и двузначных
for i := 1 to 10 do
if (arr[i] mod 3 = 0) and (arr[i] >= 10) and (arr[i] <= 99) then
sum := sum + arr[i];
writeln('Сумма элементов, кратных 3 и двузначных: ', sum);
readln;
end.
Как работает программа:
- Сначала мы объявляем массив
arrиз 10 элементов типаinteger. - Затем мы инициализируем генератор случайных чисел с помощью процедуры
randomize. - Далее мы заполняем массив
arrслучайными числами от 10 до 99 с помощью циклаfor. - Мы инициализируем переменную
sumнулем, так как сначала сумма элементов равна нулю. - Затем мы проходим по всем элементам массива
arrс помощью циклаfor. - Внутри цикла мы проверяем, является ли текущий элемент кратным 3 и двузначным с помощью операторов
modиand. - Если элемент удовлетворяет условию, то мы добавляем его к сумме
sum. - После цикла мы выводим результат на экран с помощью процедуры
writeln.
Надеюсь, это помогло! Если у вас есть какие-либо вопросы, не стесняйтесь задавать их.
Топ вопросов за вчера в категории Информатика
Информатика 11
Информатика 1255
Информатика 115
Информатика 1220
Информатика 11
Информатика 10
Информатика 66
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
