Вопрос задан 26.04.2021 в 10:59.
Предмет Информатика.
Спрашивает Катин Кирилл.
Прошу, ребят.. В ПАСКАЛЕЕЕЕ Составьте программу, находящую из трех чисел X, Y, Z наибольшее.
Сначала выбрать наибольшее число из двух – X, Y и присвоить полученное значение переменной С, затем выбрать наибольшее из чисел С и Z и присвоить полученное значение переменной CОтветы на вопрос
Отвечает Ахматова Анастасия.
var x,y,z,c: integer;
begin
write('x, y, z:');
readln(x,y,z);
if x>y then c:=x else c:=y;
if z>c then c:=z;
writeln('c = ',c);
end.
Пример:
x, y, z:
5 8 4
c = 8
begin
write('x, y, z:');
readln(x,y,z);
if x>y then c:=x else c:=y;
if z>c then c:=z;
writeln('c = ',c);
end.
Пример:
x, y, z:
5 8 4
c = 8

Отвечает Недовесова Анастасия.
/////////////////////////////////////
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на Паскале:
scssprogram FindMax;
var
X, Y, Z, C: integer;
begin
{вводим три числа}
write('Введите X: ');
readln(X);
write('Введите Y: ');
readln(Y);
write('Введите Z: ');
readln(Z);
{находим наибольшее число из X и Y}
if X > Y then
C := X
else
C := Y;
{находим наибольшее число из C и Z}
if Z > C then
C := Z;
{выводим результат}
writeln('Наибольшее число: ', C);
end.
Сначала программа запрашивает три числа у пользователя, затем находит наибольшее число из X и Y и записывает его в переменную C. Затем программа находит наибольшее число из C и Z и записывает его в ту же переменную C. В конце программа выводит на экран найденное наибольшее число.
Топ вопросов за вчера в категории Информатика
Информатика 20
Информатика 23
Информатика 21
Информатика 29
Информатика 21
Информатика 20
Информатика 25
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
